Mnsin博客
立即登录 马上注册

我们在公司做向项目的时候真的谁也不能保证自己永远都是从零开始,也会接到二开的项目,或者修改老项目的BUG,这也是我今天遇到的问题,当项目下载下来,下依赖的时候就报错了。

一、下载依赖报错

这里报错了也就没后面的剧情了,就像电视剧刚开局主角就嗝屁了,看看执行 npm i 的时候报错类容:
node-sass安装报错及其解决方案(三步解决法)

二、解决方案

1、下载源在国外,更换中国镜像源,删除package.json中的node-sass,分别下载node包和node-sass的依赖包

1
2
//更换淘宝镜像源
npm config set registry http://registry.npmmirror.com

//按照需要的node-sass版本进行安装,node-sass是4.14.1

1
npm install node-sass@4.14.1

最后运行项目即可
2.第二种方法是前面的操作是一样的(高版本的node 找不到匹配的node-sass)
2.1同样先删除删除package.json中的node-sass并卸载node-sass

1
npm uninstall node-sass

2.2安装sass: 当前最新版本:1.50.0

1
npm install sass@1.26.5 --save-dev

2.3安装sass-load 当前最新版本:12.6.0

1
npm install sass-loader@7.3.1

2.4编译安装 或者删除node_modules文件夹编译安装

1
npm install

2.5运行项目

1
npm run dev

好了,我们起飞了

node-sass安装报错及其解决方案(三步解决法)

本站所有文章、图片、资源等如无特殊说明或标注,均为来自互联网或者站长原创,版权归原作者所有;仅作为个人学习、研究以及欣赏!如若本站内容侵犯了原著者的合法权益,可联系我们进行处理,邮箱:weiyong9898@163.com
赞(3) 打赏
标签:

上一篇:

下一篇:

相关推荐

0 条评论关于"node-sass安装报错及其解决方案(三步解决法)"

表情

最新评论

    暂无留言哦~~
谢谢你请我吃鸡腿*^_^*

支付宝扫一扫打赏

微信扫一扫打赏